Back to overview
Downtime
Elevated errors on API calls
Aug 13 at 12:53am PDT
Affected services
platform.keywordsai.co
Resolved
Aug 13 at 12:58am PDT
A fix has been deployed to fix this.
Affected services
Created
Aug 13 at 12:53am PDT
Platform APIs were down due to high traffic.
Affected services